5 советов для начинающих программистов 1С | 1s-up.ru


Здравствуйте!

Этот проект создан, чтобы помочь людям, имеющим гуманитарное образование и занимающимся разработкой в 1С, а также новичкам, осваивающим 1С версии 8.x. Проект ориентирован в основном на людей, которые не имеют технического образования связанного с IT-технологиями, но по тем или иным причинам должны изучать это ремесло, или же просто проявили интерес. Но я думаю, он будет интересен всем, кто приступил к знакомству с программированием в 1С.

Популярные статьи:

Описание программы 1С для начинающих

Список баз 1С

О формах 1С

Временное хранилище в 1С 8.2

Квалификаторы и ОписаниеТипов

Последние статьи:

ДвиженияИГраницыПериода в 1С

Программное создание элементов управляемых форм 1C

Как создать Таблицу значений из области Табличного документа

1с и WinHttp.WinHttpRequest. The certificate authority is invalid or incorrect

Заметки по экзамену по платформе 1С 8.х

Запрос. Объединить. Без дубликатов

Как установить текущую строку в 8.2 Управляемые формы

Запрос 1С. Визуализация соединений таблиц

Связи параметров выбора

Уроки по внутреннему языку программирования 1С 8.3 для начинающих

«Я думаю, что каждому стоит учиться
программированию, потому что это учит
людей думать» — Стив Джобс (Основатель Apple)

Основы языка программирования 1С 8.3, представленные в уроках ниже,  предназначены для начинающих программистов.

Для тех, кто не программировал раньше на других языках. Для тех у кого язык 1С — первый в их списке.

Если же вы уже владеете 1С на некотором уровне, то возможно вам лучше сразу перейти к упражнениям (ссылка) для продвинутых.

Обычно такие люди — достаточно опытные пользователи 1С. Они хорошо разбираются в одной из предметных областей. Это и внедренцы и консультанты, и главные бухгалтеры. В своей профессии они достигли уже такого уровня, что начинают осваивать смежные.

И это правильно, потому что знание элементарных основ программирования позволит специалисту в любой предметной области достичь новых высот в своём деле.

Например, бухгалтер, владеющий основами программирования и конфигурирования 1С сможет не только автоматизировать свою деятельность без помощи программистов, найти ошибки и понять, почему программа выдает тот или иной результат. Но если ему и понадобится помощь программистов — он сможет разговаривать с ними на одном языке. Грамотно ставить задачи.

Программирование 1с

А это уже 50% успеха.

Итак, вы решили освоить профессию программиста 1С (или хотя бы её основы) и не знаете с чего начать? Растерянность на этом этапе вполне понятна. И тут бесполезно лезть в конфигуратор и сразу пытаться делать новые справочники, документы и прочие объекты, которые создаются при помощи мышки.

Самое главное, что вам нужно сделать, это усвоить суть программирования. Ухватить сам принцип выполнения программы. А для этого нужно не объекты новые создавать в базе, а изучать основы самого языка программирования 1С 8. А всё остальное уже потом приложится и будет изучено быстро и легко.

Итак, начнем!

№1: установка 1С и ваша первая программа на языке 1С
№2: основные правила языка 1С
№3: типы данных в 1С
№4: имена переменных в 1С
№5: простые логические выражения в 1С
№6: сложные логические выражения в 1С
№7: условная команда в 1С
№8: циклы в 1С часть 1
№9: циклы в 1С часть 2
№10: комбинирование простых конструкций в 1С
№11: массивы в 1С
№12: структуры в 1С
№13: функции и процедуры в 1С часть 1
№14: функции и процедуры в 1С часть 2
№15: отладка в 1С
№16: синтакс-помощник 1С
№17: работа с датами в 1С
№18: математика в 1С
№19: формат в 1С
№20: использование диалогов в 1С
№21: список значений в 1С

.

 Бесплатное обучение 1с Предприятие 8.2

Многих пользователей интересует бесплатное обучение 1с Предприятие. Поэтому, мы расскажем, как работать в этой программе, и предоставим видеоурок для наглядности. Видео имеет длительность почти 3 часа, и очень подробно показывает каждый шаг, поэтому даже новым пользователям будет легко подружиться с этой программой. Для более удобного просмотра рекомендуем ускорить просмотр через меню Настройки — Скорость (параметр 1.5).

 

В начале данного бесплатного обучения 1с показано, как зайти в приложение, выбрав своего пользователя и указав пароль.

Программирование в 1С 8.3 с нуля — краткий самоучитель

Сразу после этого перед вами открывается меню, на котором автор ролика подробно останавливается, рассказывая о каждой вкладке. Вы узнаете, что такое справочники, документы и отчеты, и для чего они предназначены.

Бесплатное обучение 1с идеально начинать по видеороликам из YouTube. А это видео, как нельзя лучше, описывает азы работы в программе. Оно очень содержательно, и все рассказывается на понятном языке. Всего за 2 часа просмотра вы с нуля сможете неплохо ориентироваться в программе. После этого можно смело скачать пробную версию 1с и закрепить свои навыки.

Если говорить конкретно, бесплатное обучение 1с на этом видео затронет такие справочники, как номенклатура, контрагенты, физические лица. Из документов мы рассмотрим Заказы покупателей. Также, в видеоуроке будем работать с отчетом Ведомость товаров на складах, в котором будут сформированы описанные выше документы.

Бесплатное обучение 1с с помощью видеоуроков неоднократно показало свою эффективность. Вы можете учиться в любое свободное время. При этом, процесс учебы максимально прост и понятен. Вам остается только мотивировать себя просматривать один ролик за другим, чтобы становиться все более опытным пользователем программы.

Чтобы продолжить бесплатное обучение 1с, вы можете скачать видеоролики 1с.

Вы можете оставить комментарий, или ссылку на Ваш сайт.

Как записать документ из модуля формы 1с8.2?

Я
   jurayed

 

06.07.11 — 19:20

Как записать документ из модуля формы 1с8.2?

 
 
   Reaper_1c

 

1 — 06.07.11 — 19:22

Взять и Записать()

   jurayed

 

2 — 06.07.11 — 19:34

&НаСервере
Процедура ГруппировкаТабЧастей() Записан = Записать(); Если Записан Тогда ДокОбъект = Объект.Ссылка.ПолучитьОбъект(); КонецЕсли; КонецПроцедуры Недостаточно фактических параметров (Записать) А туплю конечно, но подскажите плз — в чем, вроде Записать(<ПараметрыЗаписи>) Параметры:
<ПараметрыЗаписи> (необязательный)
   Fram

 

3 — 06.07.11 — 19:38

в 8.2 не силен.. может Объект.Записать() ?

   jurayed

 

4 — 06.07.11 — 19:40

не, такого метода нету, там «метод не обнаружен»

   МимохожийОднако

 

5 — 06.07.11 — 19:40

Спроси у СП

   Fram

 

6 — 06.07.11 — 19:41

а так? РеквизитФормыВЗначение(«Объект»).Записать()

   jurayed

 

7 — 06.07.11 — 19:44

(6) Неа, точно не пройдет, пробовал …

   Fram

 

8 — 06.07.11 — 19:46

(7) уверен?

Рубрика: 1С Программирование

вот кусок из БСП &НаСервере Функция ОкончаниеРедактированиеФормыЗаполнения(РежимЗаписи) ПреобразоватьРезультатыЗаполненияРазделаВТабличнуюЧасть(); Если РежимЗаписи = РежимЗаписиДокумента.Проведение Тогда Если ПроверитьЗаполнениеАнкеты() Тогда Возврат Истина; КонецЕсли; КонецЕсли; ДокументОбъект = РеквизитФормыВЗначение(«Объект»); ДокументОбъект.ДатаРедактирования = ТекущаяДата(); ДокументОбъект.Записать(РежимЗаписи); Если РежимЗаписи = РежимЗаписиДокумента.Запись Тогда ЗначениеВРеквизитФормы(ДокументОбъект,»Объект»); Модифицированность = Ложь; КонецЕсли; Возврат Ложь; КонецФункции

   jurayed

 

9 — 06.07.11 — 19:47

СТранно &НаКлиенте все прошло нормально !
просто
Записать()

   jurayed

 

10 — 06.07.11 — 19:49

(8) Спасибо, видимо я что то недописывал …

 
 

   Господин ПЖ

 

11 — 06.07.11 — 19:52

поздравляю… вы сидите в толстом клиенте что ли? или вообще совместимость включена/форма обычная

 

Наведи порядок в своей работе используя конфигурацию 1C "Управление IT-отделом 8"

ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку «Обновить» в браузере.

Ветка сдана в архив. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.

1С-программирование

Самоучители по 1С-программированию

Основы программирования на платформе 1С 8.3 (2015)

Эти видеоуроки могут осваивать люди, мало знакомые с программированием, они для новичков. Их цель — научить основам программирования на платформе 1С. Если у вас нет самой платформы 1С 8.3, то вы получите и ее, учебный вариант.

Осваивать уроки вы сможете онлайн, или скачать их, по отдельности, к себе на компьютер. Платформа 1С успешно развивается, ее «ареал» расширяется, а востребованность 1С-программистов постоянно растет. Зарплата в 100 тыс.руб. в этой профессии не является чудом.

подробнее о видеоуроках…

Язык запросов — основа программирования 1С (2015)

Бесплатные видео уроки по ускоренному изучению языка запросов 1С на платформе 8.3. Обучение даст возможность извлекать любые данные из базы в удобном виде. Опытные преподаватели сделают ваше обучение легким и интересным.

Встроенный язык программирования 1С:Предприятие

Уроки не содержат пустой информации, они продуктивны и имеют четкую конкретику.

подробнее о видео…

Приложение под Андроид на мобильной платформе 1С с нуля (2016) — 65 мин.

Бесплатные уроки по разработке собственного приложения под ОС Андроид, используя мобильную платформу 1С:Предприятие. Уроки компактные и имеют исключительно практическую направленность: у вас останется работоспособное мобильное приложение, которое вы сделали с нуля.

подробнее об уроках…

Конфигурация «Конвертация данных» в 1С:Предприятие (2014)

Несколько бесплатных уроков по Конфигурации «Конвертация данных» в 1С:Предприятие. Вы узнаете, как перенести данные из предыдущих версий в новые, например: из версии 7.7 в 8.1, или из 8 в 8.3. Видеокурс будет полезен для новичков, а специалисты получат возможность повысить квалификацию.

подробнее о видеокурсе…

1С:Управление небольшой фирмой 8.2 с нуля (2013) — 11.7 MB

Конфигурация «1С:Управление небольшой фирмой 8.2» — многофункциональная программа для малого и среднего бизнеса. Представляет абсолютно новые решения для упрощения финансовой деятельности компаний с учетом современных требований.

Книга написана понятным языком и оснащена качественными иллюстрациями. Подойдет для абсолютных новичков и расскажет об использовании программы, начиная с самых азов.

подробнее о книге…

Технологии интеграции «1C:Предприятия 8.2» (2011) — 16.8 MB

Учебник по 1С программированию «Технологии интеграции 1C:Предприятия 8.2» предназначен для разработчиков, будет полезен специалистам, желающих знать функции и архитектуру системы 1C:Предприятие 8.2, ее возможностей по реализации механизмов создания приложений и решения прикладных задач.

В учебнике по 1С освещаются: технологии интеграции платформы 1C:Предприятия 8.2 со сторонними информационными системами; механизмы обмена данными между составными частями распределенной (территориально) информационной системы; Web-расширение — специальный компонент платформы для создания веб-ресурсов, где пользователи получат возможность работать с информационной базой 1С:Предприятия из обычного браузера.

подробнее об учебнике…

1С:Розница 8.2.

Оперативный и управленческий учет на компьютере (2011) — 15 MB

Самоучитель по 1С:Розница 8.2 раскрывает все возможности этой системы. Это готовое решение для торговых предприятий по автоматизации рабочего процесса и организации учета движения товара и денежных средств.

Самоучитель дает полное представление об архитектуре 1С:Розница 8.2 и работе в системе. Будет полезен служащим, менеджерскому звену и руководителям торговых сетей и предприятий.

подробнее о самоучителе…

1С:Битрикс. Управление сайтом (2010) — 248 MB

Обучающее видео по программному пакету 1С:Битрикс-Управление сайтом «Бизнес» ориентирован на обычных пользователей, без специальной подготовки.

Видео показывает, как установить пакет 1С:Битрикс-Управление сайтом, настроить систему, расскажет об административных полномочиях, познакомит с работой в редакторе.

подробнее о видео…

Заинтересованному кругу лиц и друзьям:

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *